Bezpiecznik polimerowy

Tym razem chciałbym przedstawić rozwiązanie problemu z pojawiającym się undervoltage, resetowaniem się malinki, oraz uszkodzeniem systemu na karcie pamięci (brak możliwości uruchomienia systemu). Uszkodzenie systemu na karcie pamięci często występuje gdy w nieodpowiednim momencie odłączymy zasilanie – przeważnie podczas zapisu jakichś systemowych plików, w tym momencie zostaną one źle zapisane, bądź nie do końca i już malinka nie powstanie.

W moim przypadku za komunikat undervoltage, jak i za uszkodzenie systemu, odpowiedzialny był bezpiecznik polimerowy. Wszystko było dobrze, do momentu, kiedy w pokoju temperatura nie wzrosła, np. w lato. W zimę było wszystko w porządku (w pokoju nie utrzymuję temperatury większej jak 22,5 stopnia). Aby zdiagnozować problem należy w pierwszej kolejności sprawdzić zasilanie przed tym bezpiecznikiem – najlepiej sprawdzić to na pinach 4 oraz 6. Jeżeli napięcie jest około 5VDC to wszystko z zasilaczem mamy w porządku, w przeciwnym razie, musimy sprawdzić nasz zasilacz. Następnie sprawdzamy napięcia na pinach 1 i 6. Jeżeli mam 3.3VDC to problem jest gdzieś indziej. W moim przypadku napięcie wynosiło ponad 2,5VDC zbyt mało aby malinka dobrze pracowała.

Problemem w tym przypadku okazał się bezpiecznik polimerowy, który ogólnie mówiąc zwiększa swoją rezystancję przy zwiększonym poborze prądu – przy odpowiednim prądzie zaczyna się nagrzewać, co powoduje zwiększanie swojej rezystancji, czyli taki termistor, lecz zmiana rezystancji odbywa się skokowo.

Więc w pierwszej kolejność należy zlokalizować ten bezpiecznik. W tym celu otwieramy schemat naszej malinki – schematy RPI można pobrać ze strony https://www.raspberrypi.org/documentation/hardware/raspberrypi/schematics/

Powyższy obrazek pochodzi z wcześniej wymienionej strony

Jak można zauważyć bezpiecznik jest od razu za złączem micro USB – oznaczenie bezpiecznika to F1.

Są dwie możliwości rozwiązania tego problemu:

  1. Wymiana bezpiecznika polimerowego;
  2. Zastosowanie zworki.

Analizując inne schematy RPI, zauważyłem, że wersja 4 nie posiada takiego zabezpieczenia, więc postanowiłem zastosować zworkę w postaci cienkiego drucika. Drugim powodem był brak w szybkim dostępie do takiego bezpiecznika, a miałem potrzebę uruchomić malinkę jak najszybciej.

Po zastosowaniu zworki, malinka żyje, i ma się dość dobrze – od lipca 2019r. nie pojawił się komunikat informujący o undervolatage, oraz nie został uszkodzony system.

Tak więc w moim przypadku problem został rozwiązany. Mam nadzieję, że też udało Ci się rozwiązać problem z undervoltage.

Pozdrawiam.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany. Wymagane pola są oznaczone *